依赖环境详细说明

#操作系统

部署操作系统只支持 Linux (只支持64位系统)
开发环境目前支持 MacOs 和 Linux (只支持64位系统)

目前在如下系统上 zendAPI 编译通过:(X86_64)

  1. MacOS 10.12.6 (开发)
  2. openSUSE 42.2 (部署和开发)
  3. Ubuntu 16.04 (部署和开发)
  4. CentOS 7 (部署)

暂时没来的及测试的有 (X86_64)

  1. Deepin (开发)
  2. Fedora 26 (开发)
  3. Debian 8 (部署)

在操作系统的选择上推荐使用相对比较新的主流长期支持的版本

#编译器

目前 zendAPI 只在 GCC 和 Clang 进行相关测试,目前也是推荐使用这两个主流的编译器。
在 Linux 平台上的编译器支持情况如下:

  1. GCC 4.8.5 及其以上版本
  2. Clang 3.5.2 及其以上版本

在 MacOS 平台上的编译器支持情况如下:

  1. GCC 5.4 及其以上版本 (推荐使用 GCC 6.0 及其以上版本,GCC 6.0 以下会使用 Clang 汇编器,从而导致很多连接时候的 warning 信息,如果您有好的解决方案,请让我知道,非常感谢)
  2. Clang 3.5.0 及其以上版本

咱们使用 MacOS 主要是用来做开发环境,所以推荐使用主流编译器的最新发布版本

#PHP 语言

目前 zendAPI 开发的目标 PHP 版本号是 7.1.5 , 大家测试项目功能的时候最好选择这个版本。
下一步工作的目标 PHP 版本有:

  1. PHP 7.0
  2. PHP 7.1
  3. PHP 7.2